Visual Studio 2012 RC – Error on app model version

following error will occurred while trying to run sample application which downloaded with the “Microsoft_Press_eBook_Programming_Windows_8_Apps”. from Mocrosoft website.

Note : Downloaded Location – Microsoft_Press_eBook_Programming_Windows_8_Apps

Error on App model version

Error on App model version

I think you moreover have experience this while you developing Metro Apps in Visual Studio 2012 RC on Windows 8.

Error 1 Error : DEP0800 : The required framework “C:\Program Files\Microsoft SDKs\Windows\v8.0\ExtensionSDKs\Microsoft.WinJS.1.0\1.0\Microsoft.WinJS.1.0.appx” failed to install. Windows cannot install package Microsoft.WinJS.1.0 because this package requires a higher Windows version. The package requested Windows version 6.2 with AppModel version 1, while the current Windows version is 6.2 with AppModel version 0.

This issue occurred because of we are trying to develop Metro style apps using Visual Studio 2012 RC. But, if we need to run this sample apps properly, it is necessary to download & install Visual Studio 2012 RTM version on your developer machine.

There are some concern on installing Visual Studio 2012 RTM. VS 2012 RTM is not supported on the Windows 8 Release Preview, you need to install Windows 8 RTM first before install the Visual Studio 2012 RTM. In addition, if you have install beta version, it is necessary to uninstall the Beta version before trying to install the VS 2012 RTM version. See more information approximately “Upgrading from Visual Studio 2012 RC to RTM“.

 

 

 

Articles on Metro Apps Development




Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>